Задача. Дано натуральное число N (1lt;=Nlt;=100000). Требуется написать программу, опре?
Задача.
Дано натуральное число N (1<=N<=100000).
Требуется написать программу, опре??еляющую для
N, какая цифра больше – первая или последняя.
Формат входных данных:
В единственной строке задано число N.
Формат выходных данных:
В единственной строке необходимо вывести один
символ: =, если цифры одинаковые,
<, если первая цифра меньше последней,
>, если первая цифра больше последней.
Ответ(ы) на вопрос:
Var n,k:integer;
begin
readln(n);
k:=n mod 10;
n:=n div 10;
while n>10 do n:=n div 10;
if k=n
then writeln('=')
else if n<k then writeln('<') else writeln('>');
end.
Пример:
652843
>
Не нашли ответ?
Похожие вопросы