Задание: Написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания. Написать программу, получающую с клавиатуры целое число и выводящую его наоборот (Наприме...
Задание:
Написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания.
Написать программу, получающую с клавиатуры целое число и выводящую его наоборот
(Например: вводим: 123, а выводит: 321).
Ответ(ы) на вопрос:
Гость
Var
A:longint;
B:boolean;
Begin
B:=true;
Write('Введите целое число: ');ReadLn(A);
A:=Abs(A);
While A div 10 > 0 do
Begin
if A mod 10 < A div 10 mod 10 then B:=false;
A:=A div 10
End;
if B then Write('Верно')
else Write('Не верно')
End.
Var
A:longint;
Begin
Write('Введите целое число: ');ReadLn(A);
if A < 0 then
Begin
Write('-');
A:=-A;
End;
While A > 0 do
Begin
Write(A mod 10);
A:=A div 10
End;
End.
Не нашли ответ?
Похожие вопросы