Дана строка символов s и,далее,отдельно в новой строке дан одиночный символ с.Напишите программу,которая подсчитает,сколько раз символ с встретился в данной строке s.Составить блок-схему,не используя цикл с параметром.
Дана строка символов s и,далее,отдельно в новой строке дан одиночный символ с.Напишите программу,которая подсчитает,сколько раз символ с встретился в данной строке s.Составить блок-схему,не используя цикл с параметром.
Ответ(ы) на вопрос:
Гость
Var S:string;
C:char;
i,k:integer;
Begin
WriteLn('Введите строку');
ReadLn(S);
WriteLn('Введите символ');
ReadLn(C);
i:=1;
k:=0;
While i<=Length(S) do
Begin
if S[i] = C then k:=k+1;
i:=i+1
End;
WriteLn(k);
End.
Не нашли ответ?
Похожие вопросы