Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно). 

Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно). 
Гость
Ответ(ы) на вопрос:
Гость
var   i,k,m,j:integer;   a,b:array[1..10]of integer; begin writeln('Исходный массив:'); for i:=1 to 10 do   begin   a[i]:=random(50);   write(a[i]:3);   end; writeln; write('Введите k и m: '); readln(k,m); j:=m; for i:=k to m do   begin   b[j]:=a[i];   j:=j-1;   end; for i:=k to m do  a[i]:=b[i]; writeln('Измененный массив:'); for i:=1 to 10 do  write(a[i]:3); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы