Помогите пожалуйста) На языке Pascal составить программу, которая находит номер первого встречающегося в массиве числа 7.
Помогите пожалуйста)
На языке Pascal составить программу, которая находит номер первого встречающегося в массиве числа 7.
Ответ(ы) на вопрос:
Гость
//Предположим, что массив уже дан
var
NAME_OF_ARRAY : array [1.. 10] of integer := (1,1,7,1,7,1,5,7,4,10);
//Дальше программа. Ей всё равно, какой массив дан, главное, чтобы первый индекс был равен 1
begin
var i : integer := 1; foreach ai : integer in NAME_OF_ARRAY do
begin
if ai = 7 then
begin
writeln(i);
break;
end
else
i += 1;
end;end.
Не нашли ответ?
Похожие вопросы