Помогите, пожалуйста с задачами в "Паскале"!1. Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. Проверьте алгоритм трассировкой.(Объясните за одно, что такое "трассировк...
Помогите, пожалуйста с задачами в "Паскале"!
1. Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. Проверьте алгоритм трассировкой.(Объясните за одно, что такое "трассировка")
2. Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N. Проверьте алгоритм трассировкой.
Ответ(ы) на вопрос:
1)
var
i, n, m: integer;
begin
readln(n);
for i := 1 to n do
m := m + i;
writeln('сумма всех натуральных чисел не превышающих ', n, ' - ', m);
end.
2)
var
x, n, i, p: integer;
begin
write('Число: ');
readln(x);
write('Степень :> ');
readln(n);
p := 1;
for i := 1 to n do
p := p * x;
writeln('Результат: > ', p);
end.
Не нашли ответ?
Похожие вопросы