С клавиатуры вводится трехзначное число. Составьте программу выводящую сумму его чисел.
С клавиатуры вводится трехзначное число. Составьте программу выводящую сумму его чисел.
Ответ(ы) на вопрос:
var
a, s: integer; // целочисленный тип данных
begin
writeln('Введите число:');
readln(a); // вводим число (можно больше трех знаков)
while a <> 0 do // пока остались цифры в числе выполнять...
begin
s := s + (a mod 10); // Отбираем последнюю цифру числа и прибавляем к сумме
a := a div 10; // Стираем последнюю цифру числа
end;
writeln('Сумма цифр = ', s) // выводим результат
end.
Не нашли ответ?
Похожие вопросы