Из n случайных чисел в интервале [10;200) найти количество и сумму нечетных чисел. Написать программу.
Из n случайных чисел в интервале [10;200) найти количество и сумму нечетных чисел. Написать программу.
Ответ(ы) на вопрос:
program name;
var i,n,x,summa,count:integer;
begin
Writeln('Vvedite n: ');
readln(n);//кол во чисел
summa:=0;
count:=0;
Randomize;
for i:=1 to n do//цикл выполняется n раз
begin
x := random(189)+10;//получаем слуайное число из интервала
if(x mod 2 = 1) then//проверяем число на нечетность, если да то считаем
begin
summa:=summa+x;
count:=count+1;
writeln('ne chetnoe');//выводи число четное или нет (можно убрать строку)
end;
writeln(x);//пишем само число (можно убрать строку)
end;
writeln('Kolvo: ', count,' summa: ', summa);//выводим сумму и количество
readln();
end.
Не нашли ответ?
Похожие вопросы