Напишите программу пожаалуйста сроочно!!)) Дан массив действительных чисел.Среди них есть равные .Найти первый максимальный элемент массива и заменить его нулём 

Напишите программу пожаалуйста сроочно!!)) Дан массив действительных чисел.Среди них есть равные .Найти первый максимальный элемент массива и заменить его нулём 
Гость
Ответ(ы) на вопрос:
Гость
Program num1; Uses crt; Var x:array[1..10] of real; max:real; i : integer; Begin clrscr; for i:=1 to 10 do begin write('x[',i,']=');readln(x[i]) end; max:=x[1]; for i:=1 to 10 do if x[i]>=max then max:=x[i]; Writeln('Max=',max:3:1); for i:=1 to 10 do if x[i]=max then begin x[i]:=0;break end; for i:=1 to 10 do write(' *',x[i]:3:1,'* '); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы