Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю ц?

Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю ц??фру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N. По заданному N найти число X (значение N вводится с клавиатуры, 10<=N<=999 , и при этом число десятков в N не равно нулю).
Гость
Ответ(ы) на вопрос:
Гость
Если было число ABC = X, то после деления на 10 стало AB, а после приписывания слева CAB = N. Для получения из N числа X просто переставляем первую цифру в конец. var   N: integer; begin   readln(N);   write(10 * (N mod 100) + (N div 100)) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы