Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице измерения времени и переводит данное число во все остальны...

Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице измерения времени и переводит данное число во все остальные единицы измерения времени. Ввод чисел заканчивается нажатием клавиши 0. Протокол работы программы: Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 1 Введите значение этой единицы времени: 3600 Ответ: 3600 сек = 60 мин = 1 час = 0,042 суток Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 4 Введите значение этой единицы времени: 1 Ответ: 1 суток = 24 час = 1440 мин = 86 400 сек Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 0 Пока!
Гость
Ответ(ы) на вопрос:
Гость
Var A,R:integer; Begin WriteLn('Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.'); ReadLn(R); While R<>0 do    Begin    Write('Введите значение этой единицы времени: ');    ReadLn(A);    Case R of    1:WriteLn(A,' сек = ',(A/60):0:3,' мин = ',(A/3600):0:3,' ч = ',(A/86400):0:3,' сут');    2:WriteLn(A,' мин = ',(A/60):0:3,' ч = ',(A/1440):0:3,' сут = ',A*60,' сек');    3:WriteLn(A,' ч = ',(A/24):0:3,' сут = ',A*3600,' сек = ',A*60,' мин');    4:WriteLn(A,' сут = ',A*24,' ч = ',A*1440,' мин = ',A*86400,' сек');    End;    WriteLn;    WriteLn('Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.');    ReadLn(R);    End; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы